Domain Name Renewal Notifications
Incident Report for HEXONET
Postmortem

Statement for Missing Data in Renewal Notifications on June 26th between 16:00 and 19:00 UTC

Issue Summary

There was an issue with scripts sending out SSL certificate renewal reminder notifications on June 26th between 16:00 and 19:00 UTC. The issue was related to the recent LIVE System Maintenance where major backend changes have been carried out.

Three emails were sent per recipient, all with an array reference in the mail body, no matter if the user had any SSL certificates at all or if any SSL certificates were up for renewal or not.

Domain management as well as the operation of our HEXONET system were not affected at any point in time. It was literally only the renewal notification itself which wasn't working as expected.

Timeline and Detailed Description of Impact

June 26th, 16:00 UTC

Our backend began sending out 5, 14 and 30 Days Renewal Notices which were holding no information but a cryptical array reference in the mail body. These notifications were sent and recipients received these mails all at once.

June 26th, 17:23 UTC

The issue has been posted on https://status.hexonet.net/ and a ticket for resolving it has been opened.

June 26th, 19:00 UTC

A temporary fix has been put into place, i.e. the relevant scripts have been stopped, subsequently no further notifications have been sent.

June 27th during the course of the day

All relevant scripts have been fixed and SSL certificate renewal notification are processed and sent out properly again.

Root Cause

As part of the recent LIVE System Maintenance the way how internal API calls were made needed to be changed for some scripts. For the SSL certificate renewal notifications quite a few adjustments were needed and as part of these adjustments the user information has not been forwarded to the internal API calls any more.

As a result every user was identified having expiring SSL certificates since the relevant query was made for the parent user which holds all the SSL certificates.

The scripts were running for about 3 hours since June 26th 16:00 UTC before they were stopped. Emails were sent during those three hours.

No Impact on Data Security

The data integrity remained fully, at no point in time any data has been compromised.

__

As always, we remain dedicated to your success and hope this background information supports your understanding for all that transpired. If you have any questions or would like to connect with our team, please always contact us at help@hexonet.support.

Your HEXONET Team ❤️

Posted Jun 28, 2022 - 15:00 UTC

Resolved
Many thanks for your continued patience with us - we can now confirm all notification services are operating as expected.
Should you have any ongoing issues, please contact support who will be happy to help.
Many thanks and apologies for any inconveniences this may have caused.

Tier 2 | CentralNic Reseller
Posted Jun 27, 2022 - 16:09 UTC
Identified
We have identified the core issue causing this error and will have a fix deployed within 24 hours.

Please refer to this status page or subscribe for all updates relating to this issue.
Posted Jun 26, 2022 - 22:29 UTC
Investigating
We are currently aware of an issue with our domain name renewal email notifications missing the data from upcoming renewals in the body of the email - domain name renewals are not affected by this bug - simply the notification emails the system issues on upcoming domain name renewals.

While we investigate this, we recommend logging into your Hexonet Control Panel by clicking HERE. Once signed in, clicking on the Bell Icon in the top right-hand corner will list your upcoming renewals.

Apologies for any inconveniences this may cause - we will post an update as soon as a fix has been identified but please contact support should there be anything in the meantime.
Posted Jun 26, 2022 - 17:23 UTC
This incident affected: Hexonet Console (Account Notifications via Email).