SSL certificate supplier outage
Incident Report for HEXONET
Resolved
The root cause has been identified as a missing Trust in the connection which has been restored by our supplier and the pending/stuck SSL orders have been resubmitted to the vendors.

Incident Start Time: 01-31-2024 02:43:00 UTC
Incident End Time: 01-31-2024 19:50:00 UTC
Total Duration: 17 hours, 7 minutes
Posted Jan 31, 2024 - 23:39 UTC
Identified
Our supplier has resolved the initial identified cause but SSL orders are currently still not processing.
Posted Jan 31, 2024 - 21:07 UTC
Update
We are continuing to investigate this issue.
Posted Jan 31, 2024 - 17:51 UTC
Investigating
Our supplier for SSL certificates identified an issue with the submission of Sectigo & Digicert certificate orders. It is currently being investigated.
Posted Jan 31, 2024 - 03:30 UTC
This incident affected: SSL Certificates (Ordering Certificates).